[BCRYPT] Improve stubs for functions needed by crypt32 aka fix build.
[reactos.git] / dll / win32 / bcrypt / bcrypt.spec
index 87623f8..b7bde3a 100644 (file)
@@ -1,15 +1,15 @@
 @ stub BCryptAddContextFunction
 @ stub BCryptAddContextFunctionProvider
-@ stub BCryptCloseAlgorithmProvider
+@ stdcall BCryptCloseAlgorithmProvider(ptr long)
 @ stub BCryptConfigureContext
 @ stub BCryptConfigureContextFunction
 @ stub BCryptCreateContext
-@ stub BCryptCreateHash
+@ stdcall BCryptCreateHash(ptr ptr ptr long ptr long long)
 @ stub BCryptDecrypt
 @ stub BCryptDeleteContext
 @ stub BCryptDeriveKey
-@ stub BCryptDestroyHash
-@ stub BCryptDestroyKey
+@ stdcall BCryptDestroyHash(ptr)
+@ stdcall -stub BCryptDestroyKey(ptr)
 @ stub BCryptDestroySecret
 @ stub BCryptDuplicateHash
 @ stub BCryptDuplicateKey
 @ stub BCryptEnumRegisteredProviders
 @ stub BCryptExportKey
 @ stub BCryptFinalizeKeyPair
-@ stub BCryptFinishHash
+@ stdcall BCryptFinishHash(ptr ptr long long)
 @ stub BCryptFreeBuffer
 @ stdcall BCryptGenRandom(ptr ptr long long)
 @ stub BCryptGenerateKeyPair
 @ stub BCryptGenerateSymmetricKey
-@ stub BCryptGetFipsAlgorithmMode
-@ stub BCryptGetProperty
-@ stub BCryptHashData
+@ stdcall BCryptGetFipsAlgorithmMode(ptr)
+@ stdcall BCryptGetProperty(ptr wstr ptr long ptr long)
+@ stdcall BCryptHash(ptr ptr long ptr long ptr long)
+@ stdcall BCryptHashData(ptr ptr long long)
 @ stub BCryptImportKey
-@ stub BCryptImportKeyPair
-@ stub BCryptOpenAlgorithmProvider
+@ stdcall -stub BCryptImportKeyPair(ptr ptr wstr ptr ptr long long)
+@ stdcall BCryptOpenAlgorithmProvider(ptr wstr wstr long)
 @ stub BCryptQueryContextConfiguration
 @ stub BCryptQueryContextFunctionConfiguration
 @ stub BCryptQueryContextFunctionProperty
@@ -49,7 +50,7 @@
 @ stub BCryptSignHash
 @ stub BCryptUnregisterConfigChangeNotify
 @ stub BCryptUnregisterProvider
-@ stub BCryptVerifySignature
+@ stdcall -stub BCryptVerifySignature(ptr ptr ptr long ptr long long)
 @ stub GetAsymmetricEncryptionInterface
 @ stub GetCipherInterface
 @ stub GetHashInterface