[CMAKE] Some options are only supported by GCC, don't use them for clang
[reactos.git] / dll / win32 / browseui / CMakeLists.txt
index d606fbf..146ee78 100644 (file)
@@ -53,8 +53,11 @@ add_importlibs(browseui uxtheme shlwapi shell32 comctl32 gdi32 ole32 oleaut32 us
 add_pch(browseui precomp.h "${PCH_SKIP_SOURCE}")
 add_cd_file(TARGET browseui DESTINATION reactos/system32 FOR all)
 
+if(CMAKE_C_COMPILER_ID STREQUAL "GNU")
+    target_compile_options(browseui PRIVATE -Wno-unused-but-set-variable)
+endif()
+
 if(NOT MSVC)
-    target_compile_options(browseui PRIVATE "-Wno-unused-but-set-variable")
     # Binutils linker bug
     if(LTCG)
         add_target_link_flags(browseui "-Wl,--allow-multiple-definition")