[BROWSEUI] CISFBand: Handle DBID_SETWINDOWTHEME. CORE-14176
[reactos.git] / dll / win32 / browseui / CMakeLists.txt
index 8283f0f..85b269f 100644 (file)
@@ -1,27 +1,31 @@
 PROJECT(SHELL)
 
+add_subdirectory(shellbars)
+
 set_cpp(WITH_RUNTIME)
 
-remove_definitions(-D_WIN32_WINNT=0x502)
-add_definitions(-D_WIN32_WINNT=0x600)
+add_definitions(
+    -D_ATL_NO_EXCEPTIONS)
 
-include_directories(${REACTOS_SOURCE_DIR}/lib/atl)
+include_directories(${REACTOS_SOURCE_DIR}/sdk/lib/atl)
 spec2def(browseui.dll browseui.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
+    ACLCustomMRU.cpp
+    ACLCustomMRU.h
+    aclistisf.cpp
     aclmulti.cpp
     addressband.cpp
     addresseditbox.cpp
     bandproxy.cpp
-    bandsite.cpp
-    bandsitemenu.cpp
-    basebar.cpp
     basebarsite.cpp
     brandband.cpp
     browseui.cpp
     browseuiord.cpp
+    CAutoComplete.cpp
     commonbrowser.cpp
     desktopipc.cpp
+    explorerband.cpp
     globalfoldersettings.cpp
     internettoolbar.cpp
     parsecmdline.cpp
@@ -30,6 +34,7 @@ list(APPEND SOURCE
     toolsband.cpp
     travellog.cpp
     utility.cpp
+    CProgressDialog.cpp
     precomp.h)
 
 add_library(browseui SHARED
@@ -39,16 +44,13 @@ add_library(browseui SHARED
     ${CMAKE_CURRENT_BINARY_DIR}/browseui.def)
 
 set_module_type(browseui win32dll UNICODE)
-target_link_libraries(browseui atlnew uuid wine)
-add_importlibs(browseui shlwapi shell32 comctl32 gdi32 ole32 oleaut32 user32 advapi32 msvcrt kernel32 ntdll)
+target_link_libraries(browseui shellbars atlnew uuid wine)
+add_importlibs(browseui uxtheme shlwapi shell32 comctl32 gdi32 ole32 oleaut32 user32 advapi32 msvcrt kernel32 ntdll)
 add_pch(browseui precomp.h SOURCE)
 add_cd_file(TARGET browseui DESTINATION reactos/system32 FOR all)
 
 if(NOT MSVC)
-    if(NOT CMAKE_C_COMPILER_ID STREQUAL "Clang")
-        add_target_compile_flags(browseui "-Wno-unused-but-set-variable")
-    endif()
-
+    add_target_compile_flags(browseui "-Wno-unused-but-set-variable")
     # Binutils linker bug
     if(LTCG)
         add_target_link_flags(browseui "-Wl,--allow-multiple-definition")