[CMAKE]
[reactos.git] / dll / win32 / crypt32 / CMakeLists.txt
index 3b0c4cf..5240252 100644 (file)
@@ -10,9 +10,11 @@ add_definitions(-D_WIN32_WINNT=0x600)
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-spec2def(crypt32 ${CMAKE_CURRENT_SOURCE_DIR}/crypt32.spec ${CMAKE_CURRENT_BINARY_DIR}/crypt32.def)
+set_rc_compiler()
 
-add_library(crypt32 SHARED
+spec2def(crypt32.dll crypt32.spec)
+
+list(APPEND SOURCE
     base64.c
     cert.c
     chain.c
@@ -38,16 +40,20 @@ add_library(crypt32 SHARED
     store.c
     str.c
     crypt32.rc
-    version.rc)
+    version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/crypt32_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/crypt32.def)
+
+add_library(crypt32 SHARED ${SOURCE})
 
 set_module_type(crypt32 win32dll)
 
 target_link_libraries(crypt32
-    ${CMAKE_CURRENT_BINARY_DIR}/crypt32.def
     wine
-    pseh
+    ${PSEH_LIB}
     oldnames)
 
 add_importlibs(crypt32 user32 advapi32 msvcrt kernel32 ntdll)
-add_dependencies(crypt32 crypt32_def)
-add_livecd_target(crypt32 reactos/system32)
+
+add_cd_file(TARGET crypt32 DESTINATION reactos/system32)
+add_importlib_target(crypt32.spec)