[CMAKE]
[reactos.git] / dll / win32 / cryptnet / CMakeLists.txt
index db8fe33..51200f6 100644 (file)
@@ -4,7 +4,12 @@ include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
 spec2def(cryptnet.dll cryptnet.spec)
 
-add_library(cryptnet SHARED cryptnet_main.c ${CMAKE_CURRENT_BINARY_DIR}/cryptnet.def)
+list(APPEND SOURCE
+    cryptnet_main.c
+    ${CMAKE_CURRENT_BINARY_DIR}/cryptnet_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/cryptnet.def)
+
+add_library(cryptnet SHARED ${SOURCE})
 
 set_module_type(cryptnet win32dll)
 
@@ -13,8 +18,9 @@ target_link_libraries(cryptnet wine)
 add_importlibs(cryptnet
     crypt32
     wininet
+    msvcrt
     kernel32
     ntdll)
 
-
-add_cab_target(cryptnet 1)
+add_importlib_target(cryptnet.spec)
+add_cd_file(TARGET cryptnet DESTINATION reactos/system32 FOR all)