[CMAKE]
[reactos.git] / dll / win32 / cryptnet / CMakeLists.txt
index 8a99887..9547075 100644 (file)
@@ -2,21 +2,25 @@
 add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-spec2def(cryptnet ${CMAKE_CURRENT_SOURCE_DIR}/cryptnet.spec ${CMAKE_CURRENT_BINARY_DIR}/cryptnet.def)
+spec2def(cryptnet.dll cryptnet.spec)
 
-add_library(cryptnet SHARED cryptnet_main.c)
+list(APPEND SOURCE
+    cryptnet_main.c
+    ${CMAKE_CURRENT_BINARY_DIR}/cryptnet_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/cryptnet.def)
+
+add_library(cryptnet SHARED ${SOURCE})
 
 set_module_type(cryptnet win32dll)
 
-target_link_libraries(cryptnet
-    ${CMAKE_CURRENT_BINARY_DIR}/cryptnet.def
-    wine)
+target_link_libraries(cryptnet wine)
 
 add_importlibs(cryptnet
     crypt32
     wininet
+    msvcrt
     kernel32
     ntdll)
 
-add_dependencies(cryptnet cryptnet_def)
-add_cab_target(cryptnet 1)
+add_importlib_target(cryptnet.spec)
+add_cd_file(TARGET cryptnet DESTINATION reactos/system32)