[CMAKE]
[reactos.git] / dll / win32 / dbghelp / CMakeLists.txt
index a148132..efa5c00 100644 (file)
@@ -13,9 +13,11 @@ endif(ARCH MATCHES amd64)
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
+set_rc_compiler()
+
 spec2def(dbghelp.dll dbghelp.spec)
 
-add_library(dbghelp SHARED
+list(APPEND SOURCE
     coff.c
     cpu_i386.c
     cpu_ppc.c
@@ -40,8 +42,11 @@ add_library(dbghelp SHARED
     symbol.c
     type.c
     version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/dbghelp_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/dbghelp.def)
 
+add_library(dbghelp SHARED ${SOURCE})
+
 set_module_type(dbghelp win32dll)
 
 target_link_libraries(dbghelp
@@ -50,5 +55,5 @@ target_link_libraries(dbghelp
     oldnames)
 
 add_importlibs(dbghelp psapi version msvcrt kernel32 ntdll)
-
+add_importlib_target(dbghelp.spec)
 add_cab_target(dbghelp 1)