[CRT] Add missing posix error codes
[reactos.git] / dll / win32 / dnsapi / CMakeLists.txt
index 7a80b3c..2dcfaa0 100644 (file)
@@ -1,10 +1,10 @@
 
 include_directories(
     include
-    ${REACTOS_SOURCE_DIR}/lib/3rdparty/adns/src
-    ${REACTOS_SOURCE_DIR}/lib/3rdparty/adns/adns_win32)
+    ${REACTOS_SOURCE_DIR}/sdk/lib/3rdparty/adns/src
+    ${REACTOS_SOURCE_DIR}/sdk/lib/3rdparty/adns/adns_win32)
 
-add_definitions(-DADNS_JGAA_WIN32)
+add_definitions(-DADNS_JGAA_WIN32 -D_CRT_NO_POSIX_ERROR_CODES)
 spec2def(dnsapi.dll dnsapi.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
@@ -17,13 +17,13 @@ list(APPEND SOURCE
     dnsapi/stubs.c
     dnsapi/precomp.h)
 
-add_library(dnsapi SHARED
+add_library(dnsapi MODULE
     ${SOURCE}
     dnsapi.rc
     ${CMAKE_CURRENT_BINARY_DIR}/dnsapi.def)
 
 set_module_type(dnsapi win32dll)
 target_link_libraries(dnsapi adns)
-add_importlibs(dnsapi user32 ws2_32 iphlpapi msvcrt kernel32 ntdll)
+add_importlibs(dnsapi advapi32 user32 ws2_32 iphlpapi msvcrt kernel32 ntdll)
 add_pch(dnsapi dnsapi/precomp.h SOURCE)
 add_cd_file(TARGET dnsapi DESTINATION reactos/system32 FOR all)