[CRT] Massively improve performance of rand_s
[reactos.git] / dll / win32 / fusion / CMakeLists.txt
index fcaa5c2..b180daf 100644 (file)
@@ -14,15 +14,15 @@ list(APPEND COMMON_SOURCE
 
 add_library(fusion_common STATIC ${COMMON_SOURCE})
 add_dependencies(fusion_common psdk)
+add_pch(fusion_common precomp.h COMMON_SOURCE)
 
-add_library(fusion SHARED
+add_library(fusion MODULE
     version.rc
     ${CMAKE_CURRENT_BINARY_DIR}/fusion.def)
 
 set_module_type(fusion win32dll)
 target_link_libraries(fusion fusion_common uuid wine)
-add_importlibs(fusion advapi32 dbghelp shlwapi user32 msvcrt kernel32 ntdll)
-add_pch(fusion_common precomp.h COMMON_SOURCE)
+add_importlibs(fusion bcrypt advapi32 dbghelp shlwapi user32 msvcrt kernel32 ntdll)
 add_cd_file(TARGET fusion DESTINATION reactos/Microsoft.NET/Framework/v1.0.3705 FOR all)
 add_cd_file(TARGET fusion DESTINATION reactos/system32 FOR all)