* Sync up to trunk HEAD (r62285). Branch guys deserve the significant speedups too ;)
[reactos.git] / dll / win32 / fusion / CMakeLists.txt
index 545c187..6704f95 100644 (file)
@@ -10,13 +10,18 @@ list(APPEND SOURCE
     asmname.c
     assembly.c
     fusion.c
-    ${CMAKE_CURRENT_BINARY_DIR}/fusion_stubs.c
+    fusionpriv.h
+    ${CMAKE_CURRENT_BINARY_DIR}/fusion_stubs.c)
+
+add_library(fusion SHARED
+    ${SOURCE}
+    version.rc
     ${CMAKE_CURRENT_BINARY_DIR}/fusion.def)
 
-add_library(fusion SHARED ${SOURCE} version.rc)
 set_module_type(fusion win32dll)
 target_link_libraries(fusion uuid wine)
 add_importlibs(fusion advapi32 dbghelp shlwapi user32 msvcrt kernel32 ntdll)
+add_pch(fusion fusionpriv.h SOURCE)
 add_cd_file(TARGET fusion DESTINATION reactos/Microsoft.NET/Framework/v1.0.3705 FOR all)
 add_cd_file(TARGET fusion DESTINATION reactos/Microsoft.NET/Framework/v1.1.4322 FOR all)
 add_cd_file(TARGET fusion DESTINATION reactos/Microsoft.NET/Framework/v2.0.50727 FOR all)