[NTOSKRNL] Drop the useless Timestamp field
[reactos.git] / dll / win32 / gdiplus / CMakeLists.txt
index 2217df5..1720891 100644 (file)
@@ -3,7 +3,7 @@ add_definitions(
     -D__WINESRC__
     -D_USE_MATH_DEFINES)
 
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
+include_directories(${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine)
 spec2def(gdiplus.dll gdiplus.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
@@ -21,9 +21,9 @@ list(APPEND SOURCE
     pen.c
     region.c
     stringformat.c
-    gdiplus_private.h)
+    precomp.h)
 
-add_library(gdiplus SHARED
+add_library(gdiplus MODULE
     ${SOURCE}
     guid.c
     gdiplus.rc
@@ -32,12 +32,14 @@ add_library(gdiplus SHARED
 
 set_module_type(gdiplus win32dll)
 target_link_libraries(gdiplus wine)
-
-if(CMAKE_C_COMPILER_ID STREQUAL "Clang")
-    target_link_libraries(gdiplus mingwex)
-endif()
-
 add_delay_importlibs(gdiplus windowscodecs)
 add_importlibs(gdiplus msvcrt shlwapi oleaut32 ole32 user32 gdi32 kernel32 ntdll)
-add_pch(gdiplus gdiplus_private.h SOURCE)
+add_pch(gdiplus precomp.h SOURCE)
 add_cd_file(TARGET gdiplus DESTINATION reactos/system32 FOR all)
+
+add_cd_file(TARGET gdiplus DESTINATION reactos/winsxs/x86_microsoft.windows.gdiplus_6595b64144ccf1df_1.1.7601.23038_none_deadbeef FOR all)
+add_cd_file(FILE ${CMAKE_CURRENT_SOURCE_DIR}/x86_microsoft.windows.gdiplus_6595b64144ccf1df_1.1.7601.23038_none_deadbeef.manifest DESTINATION reactos/winsxs/manifests FOR all)
+
+add_cd_file(TARGET gdiplus DESTINATION reactos/winsxs/x86_microsoft.windows.gdiplus_6595b64144ccf1df_1.0.14393.0_none_deadbeef FOR all)
+add_cd_file(FILE ${CMAKE_CURRENT_SOURCE_DIR}/x86_microsoft.windows.gdiplus_6595b64144ccf1df_1.0.14393.0_none_deadbeef.manifest DESTINATION reactos/winsxs/manifests FOR all)
+