[CMAKE]
[reactos.git] / dll / win32 / glu32 / CMakeLists.txt
index e32f49b..deccc40 100644 (file)
@@ -10,9 +10,9 @@ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/libnurbs/nurbtess)
 include_directories(${CMAKE_CURRENT_SOURCE_DIR}/libtess)
 include_directories(${CMAKE_CURRENT_SOURCE_DIR}/libutil)
 
-spec2def(glu32 ${CMAKE_CURRENT_SOURCE_DIR}/glu32.spec ${CMAKE_CURRENT_BINARY_DIR}/glu32.def)
+spec2def(glu32.dll glu32.spec)
 
-list(APPEND SOURCE
+add_library(glu32 SHARED
     libnurbs/interface/bezierEval.cc
     libnurbs/interface/bezierPatch.cc
     libnurbs/interface/bezierPatchMesh.cc
@@ -101,14 +101,13 @@ list(APPEND SOURCE
     libutil/mipmap.c
     libutil/project.c
     libutil/quad.c
-    libutil/registry.c)
-
-add_library(glu32 SHARED ${SOURCE})
+    libutil/registry.c
+    ${CMAKE_CURRENT_BINARY_DIR}/glu32.def)
 
 set_entrypoint(glu32 0)
 
-target_link_libraries(glu32 ${CMAKE_CURRENT_BINARY_DIR}/glu32.def)
-add_importlibs(glu32
+add_importlibs(
+    glu32
     gcc
     msvcrt
     opengl32
@@ -116,5 +115,4 @@ add_importlibs(glu32
     kernel32
     ntdll)
 
-add_dependencies(glu32 glu32_def psdk buildno_header)
-add_livecd_target(glu32 reactos/system32)
\ No newline at end of file
+add_cab_target(glu32 1)
\ No newline at end of file