[CMAKE]
[reactos.git] / dll / win32 / hhctrl.ocx / CMakeLists.txt
index cc8077c..814b5c4 100644 (file)
@@ -1,7 +1,12 @@
 
 add_definitions(-D__WINESRC__)
+
+remove_definitions(-D_WIN32_WINNT=0x502)
+add_definitions(-D_WIN32_WINNT=0x600)
+
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
+set_rc_compiler()
 spec2def(hhctrl.ocx hhctrl.ocx.spec)
 
 add_library(hhctrl SHARED
@@ -19,9 +24,7 @@ add_library(hhctrl SHARED
 
 set_module_type(hhctrl win32ocx)
 
-target_link_libraries(hhctrl
-    uuid
-    wine)
+target_link_libraries(hhctrl uuid wine itss_guid)
 
 add_importlibs(hhctrl
     advapi32
@@ -31,7 +34,8 @@ add_importlibs(hhctrl
     oleaut32
     user32
     gdi32
+    msvcrt
     kernel32
     ntdll)
 
-
+add_cd_file(TARGET hhctrl DESTINATION reactos/system32 FOR all)