[CMAKE] Implement PCH builds with target_precompile_headers. CORE-16905
[reactos.git] / dll / win32 / hlink / CMakeLists.txt
index 29ae5f9..86e5e1a 100644 (file)
@@ -7,18 +7,20 @@ list(APPEND SOURCE
     browse_ctx.c
     extserv.c
     hlink_main.c
-    link.c
-    precomp.h)
+    link.c)
+
+list(APPEND PCH_SKIP_SOURCE
+    ${CMAKE_CURRENT_BINARY_DIR}/hlink_stubs.c)
 
 add_library(hlink MODULE
     ${SOURCE}
+    ${PCH_SKIP_SOURCE}
     hlink.rc
-    ${CMAKE_CURRENT_BINARY_DIR}/hlink_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/hlink.def)
 
 set_module_type(hlink win32dll)
 target_link_libraries(hlink uuid wine)
 add_delay_importlibs(hlink urlmon)
 add_importlibs(hlink shell32 ole32 advapi32 msvcrt kernel32 ntdll)
-add_pch(hlink precomp.h SOURCE)
+add_pch(hlink precomp.h "${PCH_SKIP_SOURCE}")
 add_cd_file(TARGET hlink DESTINATION reactos/system32 FOR all)