[CMAKE]
[reactos.git] / dll / win32 / icmp / CMakeLists.txt
index 0b3f0c2..9f6b2f7 100644 (file)
@@ -1,18 +1,16 @@
 
-
-
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
 spec2def(icmp ${CMAKE_CURRENT_SOURCE_DIR}/icmp.spec ${CMAKE_CURRENT_BINARY_DIR}/icmp.def)
 
 add_library(icmp SHARED icmp_main.c icmp.rc)
 
-set_target_properties(icmp PROPERTIES LINK_FLAGS "-Wl,-entry,_DllMain@12")
+set_module_type(icmp win32dll)
 
 target_link_libraries(icmp
     ${CMAKE_CURRENT_BINARY_DIR}/icmp.def
-    wine
-    -lws2_32
-    mingw_common)
+    wine)
 
+add_importlibs(icmp ws2_32 kernel32 ntdll)
 add_dependencies(icmp icmp_def psdk)
+add_cab_target(icmp 1)