[CMAKE]
[reactos.git] / dll / win32 / imagehlp / CMakeLists.txt
index 5ed8b96..52aa1fb 100644 (file)
@@ -1,6 +1,7 @@
 
-add_definitions(-D_DLL -D__USE_CRTIMP)
-add_definitions(-D_IMAGEHLP_SOURCE_)
+add_definitions(
+    -D_DLL -D__USE_CRTIMP
+    -D_IMAGEHLP_SOURCE_)
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
@@ -12,6 +13,7 @@ list(APPEND SOURCE
     integrity.c
     modify.c
     imagehlp.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/imagehlp_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/imagehlp.def)
 
 add_library(imagehlp SHARED 
@@ -23,6 +25,8 @@ set_module_type(imagehlp win32dll)
 target_link_libraries(imagehlp wine)
 
 add_importlibs(imagehlp dbghelp msvcrt kernel32 ntdll)
+add_importlib_target(imagehlp.spec)
+
 add_pch(imagehlp ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
 
-add_cab_target(imagehlp 1)
+add_cd_file(TARGET imagehlp DESTINATION reactos/system32)