* Sync to recent trunk (r52563).
[reactos.git] / dll / win32 / imagehlp / CMakeLists.txt
index d14eed6..573098c 100644 (file)
@@ -1,8 +1,5 @@
 
-add_definitions(
-    -D_DLL -D__USE_CRTIMP
-    -D_IMAGEHLP_SOURCE_)
-
+add_definitions(-D_IMAGEHLP_SOURCE_)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
 spec2def(imagehlp.dll imagehlp.spec)
@@ -16,17 +13,11 @@ list(APPEND SOURCE
     ${CMAKE_CURRENT_BINARY_DIR}/imagehlp_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/imagehlp.def)
 
-add_library(imagehlp SHARED 
-    ${CMAKE_CURRENT_BINARY_DIR}/imagehlp_precomp.h.gch
-    ${SOURCE})
+add_library(imagehlp SHARED ${SOURCE})
 
 set_module_type(imagehlp win32dll)
-
 target_link_libraries(imagehlp wine)
-
 add_importlibs(imagehlp dbghelp msvcrt kernel32 ntdll)
 add_importlib_target(imagehlp.spec)
-
-add_pch(imagehlp ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
-
+add_pch(imagehlp precomp.h)
 add_cd_file(TARGET imagehlp DESTINATION reactos/system32 FOR all)