[CMAKE]
[reactos.git] / dll / win32 / imagehlp / CMakeLists.txt
index efc548a..d14eed6 100644 (file)
@@ -1,17 +1,20 @@
 
-add_definitions(-D_DLL -D__USE_CRTIMP)
-add_definitions(-D_IMAGEHLP_SOURCE_)
+add_definitions(
+    -D_DLL -D__USE_CRTIMP
+    -D_IMAGEHLP_SOURCE_)
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-spec2def(imagehlp ${CMAKE_CURRENT_SOURCE_DIR}/imagehlp.spec ${CMAKE_CURRENT_BINARY_DIR}/imagehlp.def)
+spec2def(imagehlp.dll imagehlp.spec)
 
 list(APPEND SOURCE
     access.c
     imagehlp_main.c
     integrity.c
     modify.c
-    imagehlp.rc)
+    imagehlp.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/imagehlp_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/imagehlp.def)
 
 add_library(imagehlp SHARED 
     ${CMAKE_CURRENT_BINARY_DIR}/imagehlp_precomp.h.gch
@@ -19,11 +22,11 @@ add_library(imagehlp SHARED
 
 set_module_type(imagehlp win32dll)
 
-target_link_libraries(imagehlp
-    ${CMAKE_CURRENT_BINARY_DIR}/imagehlp.def
-    wine)
+target_link_libraries(imagehlp wine)
+
+add_importlibs(imagehlp dbghelp msvcrt kernel32 ntdll)
+add_importlib_target(imagehlp.spec)
 
-add_importlibs(imagehlp dbghelp kernel32 ntdll)
 add_pch(imagehlp ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
-add_dependencies(imagehlp imagehlp_def)
-add_livecd_target(imagehlp reactos/system32)
+
+add_cd_file(TARGET imagehlp DESTINATION reactos/system32 FOR all)