[CMAKE]
[reactos.git] / dll / win32 / inetmib1 / CMakeLists.txt
index 0c51697..7138cf5 100644 (file)
@@ -1,11 +1,18 @@
 
-add_definitions(-D__WINESRC__)
-add_definitions(-D_DLL -D__USE_CRTIMP)
+add_definitions(
+    -D__WINESRC__
+    -D_DLL -D__USE_CRTIMP)
+
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
 spec2def(inetmib1.dll inetmib1.spec)
 
-add_library(inetmib1 SHARED main.c ${CMAKE_CURRENT_BINARY_DIR}/inetmib1.def)
+list(APPEND SOURCE
+    main.c 
+    ${CMAKE_CURRENT_BINARY_DIR}/inetmib1_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/inetmib1.def)
+
+add_library(inetmib1 SHARED ${SOURCE})
 
 set_module_type(inetmib1 win32dll)
 
@@ -18,5 +25,4 @@ add_importlibs(inetmib1
     kernel32
     ntdll)
 
-
-add_cab_target(inetmib1 1)
+add_cd_file(TARGET inetmib1 DESTINATION reactos/system32)