[ITSS] Get the stubs file out of the source files list. #179
[reactos.git] / dll / win32 / itss / CMakeLists.txt
index ad719e6..0dbf580 100644 (file)
@@ -1,7 +1,6 @@
 
 add_definitions(-D__WINESRC__)
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-
+include_directories(${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine)
 spec2def(itss.dll itss.spec)
 
 list(APPEND SOURCE
@@ -11,30 +10,18 @@ list(APPEND SOURCE
     moniker.c
     protocol.c
     storage.c
-    #${REACTOS_BINARY_DIR}/include/reactos/wine/itss_i.c
-    ${CMAKE_CURRENT_BINARY_DIR}/itss_stubs.c
-    ${CMAKE_CURRENT_BINARY_DIR}/itss.def)
+    precomp.h)
 
 add_library(itss SHARED
     ${SOURCE}
-    rsrc.rc)
+    guid.c
+    rsrc.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/itss_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/itss.def)
 
 set_module_type(itss win32dll)
 target_link_libraries(itss uuid wine)
-
-if(NOT MSVC)
-    # FIXME: http://www.cmake.org/Bug/view.php?id=12998
-    #allow_warnings(itss)
-    set_source_files_properties(${SOURCE} PROPERTIES COMPILE_FLAGS "-Wno-error")
-endif()
-
-add_importlibs(itss
-    urlmon
-    shlwapi
-    ole32
-    msvcrt
-    kernel32
-    ntdll)
-
+add_importlibs(itss urlmon shlwapi ole32 msvcrt kernel32 ntdll)
+add_pch(itss precomp.h SOURCE)
 add_dependencies(itss wineheaders)
 add_cd_file(TARGET itss DESTINATION reactos/system32 FOR all)