[ITSS] Get the stubs file out of the source files list. #179
[reactos.git] / dll / win32 / itss / CMakeLists.txt
index eb5ca6a..0dbf580 100644 (file)
@@ -1,7 +1,6 @@
 
 add_definitions(-D__WINESRC__)
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-
+include_directories(${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine)
 spec2def(itss.dll itss.spec)
 
 list(APPEND SOURCE
@@ -11,11 +10,18 @@ list(APPEND SOURCE
     moniker.c
     protocol.c
     storage.c
+    precomp.h)
+
+add_library(itss SHARED
+    ${SOURCE}
+    guid.c
+    rsrc.rc
     ${CMAKE_CURRENT_BINARY_DIR}/itss_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/itss.def)
 
-add_library(itss SHARED ${SOURCE} rsrc.rc)
 set_module_type(itss win32dll)
 target_link_libraries(itss uuid wine)
 add_importlibs(itss urlmon shlwapi ole32 msvcrt kernel32 ntdll)
+add_pch(itss precomp.h SOURCE)
+add_dependencies(itss wineheaders)
 add_cd_file(TARGET itss DESTINATION reactos/system32 FOR all)