* Sync up to trunk HEAD (r62285). Branch guys deserve the significant speedups too ;)
[reactos.git] / dll / win32 / itss / CMakeLists.txt
index 620d3d4..4861620 100644 (file)
@@ -11,12 +11,17 @@ list(APPEND SOURCE
     moniker.c
     protocol.c
     storage.c
+    precomp.h
+    ${CMAKE_CURRENT_BINARY_DIR}/itss_stubs.c)
+
+add_library(itss SHARED
+    ${SOURCE}
     guid.c
-    ${CMAKE_CURRENT_BINARY_DIR}/itss_stubs.c
+    rsrc.rc
     ${CMAKE_CURRENT_BINARY_DIR}/itss.def)
 
-add_library(itss SHARED ${SOURCE} rsrc.rc)
 set_module_type(itss win32dll)
 target_link_libraries(itss uuid wine)
 add_importlibs(itss urlmon shlwapi ole32 msvcrt kernel32 ntdll)
+add_pch(itss precomp.h SOURCE)
 add_cd_file(TARGET itss DESTINATION reactos/system32 FOR all)