[CMAKE]
[reactos.git] / dll / win32 / localspl / CMakeLists.txt
index f1e5ec4..406f201 100644 (file)
@@ -1,10 +1,13 @@
 
 add_definitions(-D__WINESRC__)
+
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
+
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
 set_rc_compiler()
+
 spec2def(localspl.dll localspl.spec)
 
 list(APPEND SOURCE
@@ -12,14 +15,14 @@ list(APPEND SOURCE
     localspl_main.c
     provider.c
     localspl.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/localspl_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/localspl.def)
 
 add_library(localspl SHARED ${SOURCE})
 
 set_module_type(localspl win32dll)
 
-target_link_libraries(localspl
-    wine)
+target_link_libraries(localspl wine)
 
 add_importlibs(localspl
     spoolss
@@ -29,5 +32,4 @@ add_importlibs(localspl
     kernel32
     ntdll)
 
-
-add_cab_target(localspl 1)
+add_cd_file(TARGET localspl DESTINATION reactos/system32)