[SHELL32] CDrivesFolder: Implement the eject and disconnect menu items. CORE-13841
[reactos.git] / dll / win32 / mapi32 / CMakeLists.txt
index 5c1484e..34677e5 100644 (file)
@@ -1,9 +1,6 @@
 
 add_definitions(-D__WINESRC__)
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-
-set_rc_compiler()
-
+include_directories(BEFORE ${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine)
 spec2def(mapi32.dll mapi32.spec)
 
 list(APPEND SOURCE
@@ -11,16 +8,19 @@ list(APPEND SOURCE
     mapi32_main.c
     prop.c
     sendmail.c
-    util.c
     stubs.c
+    util.c
+    precomp.h)
+
+add_library(mapi32 SHARED
+    ${SOURCE}
+    guid.c
     version.rc
     ${CMAKE_CURRENT_BINARY_DIR}/mapi32_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/mapi32.def)
 
-add_library(mapi32 SHARED ${SOURCE})
-
 set_module_type(mapi32 win32dll)
-
-target_link_libraries(mapi32 wine uuid)
-add_importlibs(mapi32 shlwapi shell32 user32 advapi32 msvcrt kernel32 ntdll)
+target_link_libraries(mapi32 uuid wine)
+add_importlibs(mapi32 shlwapi user32 advapi32 msvcrt kernel32 ntdll)
+add_pch(mapi32 precomp.h SOURCE)
 add_cd_file(TARGET mapi32 DESTINATION reactos/system32 FOR all)