[CMAKE] Implement PCH builds with target_precompile_headers. CORE-16905
[reactos.git] / dll / win32 / mapi32 / CMakeLists.txt
index 18da64d..35ba1de 100644 (file)
@@ -9,18 +9,20 @@ list(APPEND SOURCE
     prop.c
     sendmail.c
     stubs.c
-    util.c
-    precomp.h)
+    util.c)
+
+list(APPEND PCH_SKIP_SOURCE
+    guid.c
+    ${CMAKE_CURRENT_BINARY_DIR}/mapi32_stubs.c)
 
 add_library(mapi32 MODULE
     ${SOURCE}
-    guid.c
+    ${PCH_SKIP_SOURCE}
     version.rc
-    ${CMAKE_CURRENT_BINARY_DIR}/mapi32_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/mapi32.def)
 
 set_module_type(mapi32 win32dll)
 target_link_libraries(mapi32 uuid wine)
 add_importlibs(mapi32 shlwapi user32 advapi32 msvcrt kernel32 ntdll)
-add_pch(mapi32 precomp.h SOURCE)
+add_pch(mapi32 precomp.h "${PCH_SKIP_SOURCE}")
 add_cd_file(TARGET mapi32 DESTINATION reactos/system32 FOR all)