[REACTOS] Silence warnings in 3r-party code
[reactos.git] / dll / win32 / mciseq / CMakeLists.txt
index 8f1dd4c..6d0091f 100644 (file)
@@ -13,6 +13,9 @@ target_link_libraries(mciseq wine)
 add_importlibs(mciseq winmm user32 msvcrt kernel32 ntdll)
 add_cd_file(TARGET mciseq DESTINATION reactos/system32 FOR all)
 
-if(NOT MSVC)
+if(MSVC)
+    # Disable warning C4305: '=': truncation from 'UINT' to 'WORD'
+    target_compile_options(mciseq PRIVATE /wd4305)
+else()
     target_compile_options(mciseq PRIVATE "-Wno-overflow")
 endif()