[MSACM32] Sync with Wine Staging 3.3. CORE-14434
[reactos.git] / dll / win32 / msacm32 / CMakeLists.txt
index 4a3e8ab..88a5830 100644 (file)
@@ -1,5 +1,5 @@
 
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
+include_directories(${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine)
 spec2def(msacm32.dll msacm32.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
@@ -10,17 +10,16 @@ list(APPEND SOURCE
     msacm32_main.c
     pcmconverter.c
     stream.c
-    wineacm.h
+    precomp.h
     ${CMAKE_CURRENT_BINARY_DIR}/msacm32_stubs.c)
 
 add_library(msacm32 SHARED
     ${SOURCE}
+    msacm.rc
     ${CMAKE_CURRENT_BINARY_DIR}/msacm32.def)
 
 set_module_type(msacm32 win32dll ENTRYPOINT DllMain 12 UNICODE)
 target_link_libraries(msacm32 wine)
 add_importlibs(msacm32 advapi32 user32 winmm msvcrt kernel32 ntdll)
-add_pch(msacm32 wineacm.h SOURCE)
+add_pch(msacm32 precomp.h SOURCE)
 add_cd_file(TARGET msacm32 DESTINATION reactos/system32 FOR all)
-
-add_subdirectory(msacm32.drv)