[CMAKE]
[reactos.git] / dll / win32 / msafd / CMakeLists.txt
index a2b20f4..cdaadae 100644 (file)
@@ -1,7 +1,5 @@
 
-
-
-add_definitions(-DUNICODE -D_UNICODE)
+set_unicode()
 
 include_directories(BEFORE include)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/drivers)
@@ -20,13 +18,12 @@ add_library(msafd SHARED
     ${CMAKE_CURRENT_BINARY_DIR}/msafd_msafd.h.gch
     ${SOURCE})
 
-set_target_properties(msafd PROPERTIES LINK_FLAGS "-Wl,-entry,_DllMain@12")
+set_module_type(msafd win32dll)
 
-target_link_libraries(msafd
-    ${CMAKE_CURRENT_BINARY_DIR}/msafd.def
-    -ladvapi32
-    -lkernel32
-    -lntdll)
+target_link_libraries(msafd ${CMAKE_CURRENT_BINARY_DIR}/msafd.def)
 
 add_pch(msafd ${CMAKE_CURRENT_SOURCE_DIR}/msafd.h ${SOURCE})
-add_dependencies(msafd msafd_def psdk)
+
+add_importlibs(msafd advapi32 kernel32 ntdll)
+add_dependencies(msafd msafd_def)
+add_cab_target(msafd 1)