[CMAKE] Implement PCH builds with target_precompile_headers. CORE-16905
[reactos.git] / dll / win32 / mscoree / CMakeLists.txt
index 8cba945..2671d7a 100644 (file)
@@ -13,18 +13,20 @@ list(APPEND SOURCE
     corruntimehost.c
     metadata.c
     metahost.c
-    mscoree_main.c
-    mscoree_private.h)
+    mscoree_main.c)
+
+list(APPEND PCH_SKIP_SOURCE
+    guid.c
+    ${CMAKE_CURRENT_BINARY_DIR}/mscoree_stubs.c)
 
 add_library(mscoree MODULE
     ${SOURCE}
-    guid.c
+    ${PCH_SKIP_SOURCE}
     mscoree.rc
-    ${CMAKE_CURRENT_BINARY_DIR}/mscoree_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/mscoree.def)
 
 set_module_type(mscoree win32dll)
 target_link_libraries(mscoree uuid wine)
 add_importlibs(mscoree dbghelp advapi32 shell32 ole32 shlwapi msvcrt kernel32 ntdll)
-add_pch(mscoree mscoree_private.h SOURCE)
+add_pch(mscoree mscoree_private.h "${PCH_SKIP_SOURCE}")
 add_cd_file(TARGET mscoree DESTINATION reactos/system32 FOR all)