[CMAKE]
[reactos.git] / dll / win32 / mscoree / CMakeLists.txt
index 8a2d707..75d41f6 100644 (file)
@@ -4,14 +4,15 @@ include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
 spec2def(mscoree.dll mscoree.spec)
 
-add_library(mscoree SHARED corruntimehost.c mscoree_main.c ${CMAKE_CURRENT_BINARY_DIR}/mscoree.def)
+list(APPEND SOURCE
+    corruntimehost.c
+    mscoree_main.c
+    ${CMAKE_CURRENT_BINARY_DIR}/mscoree_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/mscoree.def)
 
-set_module_type(mscoree win32dll)
-
-target_link_libraries(mscoree
-    wine
-    uuid)
+add_library(mscoree SHARED ${SOURCE})
 
-add_importlibs(mscoree advapi32 shell32 kernel32 ntdll)
-
-add_cab_target(mscoree 1)
+set_module_type(mscoree win32dll)
+target_link_libraries(mscoree wine uuid)
+add_importlibs(mscoree advapi32 shell32 msvcrt kernel32 ntdll)
+add_cd_file(TARGET mscoree DESTINATION reactos/system32 FOR all)