Sync with trunk r63174.
[reactos.git] / dll / win32 / mscoree / CMakeLists.txt
index eaae3c5..e2ec45b 100644 (file)
@@ -15,12 +15,17 @@ list(APPEND SOURCE
     metadata.c
     metahost.c
     mscoree_main.c
+    mscoree_private.h)
+
+add_library(mscoree SHARED
+    ${SOURCE}
+    guid.c
     mscoree.rc
     ${CMAKE_CURRENT_BINARY_DIR}/mscoree_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/mscoree.def)
 
-add_library(mscoree SHARED ${SOURCE})
 set_module_type(mscoree win32dll)
-target_link_libraries(mscoree wine uuid)
+target_link_libraries(mscoree uuid wine)
 add_importlibs(mscoree dbghelp advapi32 shell32 ole32 shlwapi msvcrt kernel32 ntdll)
+add_pch(mscoree mscoree_private.h SOURCE)
 add_cd_file(TARGET mscoree DESTINATION reactos/system32 FOR all)