Sync with trunk r63174.
[reactos.git] / dll / win32 / mscoree / mscoree.spec
index 8e25cec..a51a2f1 100644 (file)
@@ -7,8 +7,9 @@
 
 @ stub CallFunctionShim
 @ stub CloseCtrs
+@ stdcall CLRCreateInstance(ptr ptr ptr)
 @ stdcall ClrCreateManagedInstance(wstr ptr ptr)
-@ stub CoEEShutDownCOM
+@ stdcall CoEEShutDownCOM()
 @ stdcall CoInitializeCor(long)
 @ stub CoInitializeEE
 @ stub CoUninitializeCor
@@ -27,8 +28,8 @@
 @ stub CorIsLatestSvc
 @ stub CorMarkThreadInThreadPool
 @ stub CorTickleSvc
-@ stub CreateConfigStream
-@ stub CreateDebuggingInterfaceFromVersion
+@ stdcall CreateConfigStream(wstr ptr)
+@ stdcall CreateDebuggingInterfaceFromVersion(long wstr ptr)
 @ stdcall -private DllCanUnloadNow()
 @ stdcall -private DllGetClassObject(ptr ptr ptr)
 @ stdcall -private DllRegisterServer()
@@ -42,7 +43,7 @@
 @ stdcall GetCORSystemDirectory(ptr long ptr)
 @ stdcall GetCORVersion(ptr long ptr)
 @ stub GetCompileInfo
-@ stub GetFileVersion
+@ stdcall GetFileVersion(wstr ptr long ptr)
 @ stub GetHashFromAssemblyFile
 @ stub GetHashFromAssemblyFileW
 @ stub GetHashFromBlob
@@ -56,9 +57,9 @@
 @ stub GetPermissionRequests
 @ stub GetPrivateContextsPerfCounters
 @ stub GetProcessExecutableHeap
-@ stub GetRealProcAddress
+@ stdcall GetRealProcAddress(str ptr)
 @ stdcall GetRequestedRuntimeInfo(wstr wstr wstr long long ptr long ptr ptr long ptr)
-@ stub GetRequestedRuntimeVersion
+@ stdcall GetRequestedRuntimeVersion(wstr ptr long ptr)
 @ stub GetRequestedRuntimeVersionForCLSID
 @ stub GetStartupFlags
 @ stub GetTargetForVTableEntry