[MSCTF] Sync with Wine Staging 3.3. CORE-14434
[reactos.git] / dll / win32 / msctf / CMakeLists.txt
index fae9512..02e172a 100644 (file)
@@ -1,6 +1,9 @@
 
+remove_definitions(-D_WIN32_WINNT=0x502)
+add_definitions(-D_WIN32_WINNT=0x600)
+
 add_definitions(-D__WINESRC__)
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
+include_directories(BEFORE ${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine)
 spec2def(msctf.dll msctf.spec)
 
 list(APPEND SOURCE
@@ -14,7 +17,7 @@ list(APPEND SOURCE
     msctf.c
     range.c
     threadmgr.c
-    msctf_internal.h
+    precomp.h
     ${CMAKE_CURRENT_BINARY_DIR}/msctf_stubs.c)
 
 add_library(msctf SHARED
@@ -24,6 +27,6 @@ add_library(msctf SHARED
 
 set_module_type(msctf win32dll)
 target_link_libraries(msctf uuid wine)
-add_importlibs(msctf ole32 oleaut32 user32 advapi32 shlwapi msvcrt kernel32 ntdll)
-add_pch(msctf msctf_internal.h SOURCE)
+add_importlibs(msctf ole32 oleaut32 user32 advapi32 advapi32_vista msvcrt kernel32 ntdll)
+add_pch(msctf precomp.h SOURCE)
 add_cd_file(TARGET msctf DESTINATION reactos/system32 FOR all)