[CMAKE]
[reactos.git] / dll / win32 / msctf / CMakeLists.txt
index d02b270..088a5e1 100644 (file)
@@ -1,13 +1,18 @@
 
-add_definitions(-D__WINESRC__)
+add_definitions(
+    -D__WINESRC__
+    -D_DLL -D__USE_CRTIMP)
+
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
-add_definitions(-D_DLL -D__USE_CRTIMP)
+
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
+set_rc_compiler()
+
 spec2def(msctf.dll msctf.spec)
 
-add_library(msctf SHARED
+list(APPEND SOURCE
     categorymgr.c
     compartmentmgr.c
     context.c
@@ -20,14 +25,13 @@ add_library(msctf SHARED
     regsvr.c
     threadmgr.c
     version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/msctf_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/msctf.def)
 
-set_module_type(msctf win32dll)
-
-target_link_libraries(msctf
-    uuid
-    wine)
+add_library(msctf SHARED ${SOURCE})
 
-add_importlibs(msctf ole32 oleaut32 user32 advapi32 kernel32 ntdll)
+set_module_type(msctf win32dll)
 
-add_cab_target(msctf 1)
+target_link_libraries(msctf uuid wine)
+add_importlibs(msctf ole32 oleaut32 user32 advapi32 msvcrt kernel32 ntdll)
+add_cd_file(TARGET msctf DESTINATION reactos/system32)