[CMAKE]
[reactos.git] / dll / win32 / msctf / CMakeLists.txt
index 1c9f187..d02b270 100644 (file)
@@ -5,7 +5,7 @@ add_definitions(-D_WIN32_WINNT=0x600)
 add_definitions(-D_DLL -D__USE_CRTIMP)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-spec2def(msctf ${CMAKE_CURRENT_SOURCE_DIR}/msctf.spec ${CMAKE_CURRENT_BINARY_DIR}/msctf.def)
+spec2def(msctf.dll msctf.spec)
 
 add_library(msctf SHARED
     categorymgr.c
@@ -19,15 +19,15 @@ add_library(msctf SHARED
     range.c
     regsvr.c
     threadmgr.c
-    version.rc)
+    version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/msctf.def)
 
 set_module_type(msctf win32dll)
 
 target_link_libraries(msctf
-    ${CMAKE_CURRENT_BINARY_DIR}/msctf.def
     uuid
     wine)
 
 add_importlibs(msctf ole32 oleaut32 user32 advapi32 kernel32 ntdll)
-add_dependencies(msctf msctf_def)
+
 add_cab_target(msctf 1)