[MSGINA] Disable exceptions in atl when compiling without exceptions
[reactos.git] / dll / win32 / msgina / CMakeLists.txt
index 7c6b561..ca47e6c 100644 (file)
@@ -1,6 +1,9 @@
 
 set_cpp(WITH_RUNTIME)
 
+add_definitions(
+    -D_ATL_NO_EXCEPTIONS)
+
 include_directories(
     ${REACTOS_SOURCE_DIR}/sdk/lib/atl
     ${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine)
@@ -19,7 +22,7 @@ list(APPEND C_SOURCE
 list(APPEND CPP_SOURCE
     dimmedwindow.cpp)
 
-add_library(msgina SHARED
+add_library(msgina MODULE
     ${C_SOURCE}
     ${CPP_SOURCE}
     msgina.rc
@@ -27,7 +30,7 @@ add_library(msgina SHARED
     ${CMAKE_CURRENT_BINARY_DIR}/msgina.def)
 
 set_module_type(msgina win32dll UNICODE)
-target_link_libraries(msgina atlnew wine uuid ${PSEH_LIB})
+target_link_libraries(msgina wine uuid ${PSEH_LIB})
 add_delay_importlibs(msgina secur32)
 add_importlibs(msgina advapi32 user32 gdi32 powrprof userenv msvcrt kernel32 ntdll)
 add_pch(msgina msgina.h CPP_SOURCE)