Sync with trunk r63793.
[reactos.git] / dll / win32 / msgsm32.acm / CMakeLists.txt
index 5617666..ba03b18 100644 (file)
@@ -1,21 +1,15 @@
 
-add_definitions(
-    -D_DLL -D__USE_CRTIMP
-    -D__WINESRC__)
-
+add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
+spec2def(msgsm32.acm msgsm32.acm.spec)
 
-add_library(msgsm32.acm SHARED msgsm32.c msgsm32.def)
-
-if(NOT MSVC)
-    set_source_files_properties(msgsm32.def PROPERTIES EXTERNAL_OBJECT TRUE)
-endif()
+list(APPEND SOURCE
+    msgsm32.c
+    ${CMAKE_CURRENT_BINARY_DIR}/msgsm32.def)
 
-set_entrypoint(msgsm32.acm 0)
+add_library(msgsm32.acm SHARED ${SOURCE})
+set_module_type(msgsm32.acm win32dll)
 set_target_properties(msgsm32.acm PROPERTIES SUFFIX "")
-
 target_link_libraries(msgsm32.acm wine)
-
 add_importlibs(msgsm32.acm winmm user32 msvcrt kernel32 ntdll)
-add_dependencies(msgsm32.acm psdk buildno_header)
-add_cab_target(msgsm32.acm 1)
+add_cd_file(TARGET msgsm32.acm DESTINATION reactos/system32 FOR all)