[CMAKE]
[reactos.git] / dll / win32 / mshtml.tlb / CMakeLists.txt
index c899231..187cd78 100644 (file)
@@ -6,19 +6,12 @@ add_definitions(-D__WINESRC__)
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-add_custom_command(
-    OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/mshtml.tlb.def
-    COMMAND native-winebuild -o ${CMAKE_CURRENT_BINARY_DIR}/mshtml.tlb.def --def -E ${CMAKE_CURRENT_SOURCE_DIR}/mshtml.tlb.spec --filename mshtml.tlb
-    DEPENDS native-winebuild)
-set_source_files_properties(${CMAKE_CURRENT_BINARY_DIR}/mshtml.tlb.def PROPERTIES GENERATED TRUE)
-add_custom_target(mshtml.tlb_def ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/mshtml.tlb.def)
+spec2def(mshtml.tlb mshtml.tlb.spec)
 
 
-add_library(mshtml.tlb SHARED rsrc.rc)
+add_library(mshtml.tlb SHARED rsrc.rc
+    ${CMAKE_CURRENT_SOURCE_DIR}/mshtml.def)
 
 set_entrypoint(mshtml.tlb 0)
 set_target_properties(mshtml.tlb PROPERTIES SUFFIX "")
 
 
 set_entrypoint(mshtml.tlb 0)
 set_target_properties(mshtml.tlb PROPERTIES SUFFIX "")
 
-
-
-add_dependencies(mshtml.tlb mshtml_tlb mshtml.tlb_def)
 add_cab_target(mshtml.tlb 1)
 add_cab_target(mshtml.tlb 1)