[3RDPARTY] Make some warnings non-fatal
[reactos.git] / dll / win32 / mshtml / CMakeLists.txt
index 00d4253..08e23da 100644 (file)
@@ -6,9 +6,14 @@ add_definitions(
     -D__WINESRC__
     -DCOM_NO_WINDOWS_H)
 
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
+include_directories(${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine)
 add_idl_headers(mshtml_nsiface_header nsiface.idl)
-spec2def(mshtml.dll mshtml.spec)
+spec2def(mshtml.dll mshtml.spec ADD_IMPORTLIB)
+
+if(MSVC)
+    # error C4028: formal parameter 3 different from declaration
+    replace_compile_flags("/we4028" " ")
+endif()
 
 list(APPEND SOURCE
     conpoint.c
@@ -16,14 +21,13 @@ list(APPEND SOURCE
     editor.c
     hlink.c
     htmlanchor.c
+    htmlarea.c
     htmlattr.c
     htmlbody.c
     htmlcomment.c
     htmlcurstyle.c
     htmldoc.c
     htmlelem.c
-    htmlelem2.c
-    htmlelem3.c
     htmlelemcol.c
     htmlembed.c
     htmlevent.c
@@ -83,13 +87,14 @@ list(APPEND SOURCE
     task.c
     txtrange.c
     view.c
+    xmlhttprequest.c
     mshtml_private.h)
 
 if(MSVC)
     add_asm_files(mshtml_asm msvc.S)
 endif()
 
-add_library(mshtml SHARED
+add_library(mshtml MODULE
     ${SOURCE}
     ${mshtml_asm}
     guid.c
@@ -105,11 +110,6 @@ list(APPEND mshtml_rc_deps
 set_source_files_properties(rsrc.rc PROPERTIES OBJECT_DEPENDS "${mshtml_rc_deps}")
 set_module_type(mshtml win32dll)
 target_link_libraries(mshtml uuid wine strmiids oldnames)
-
-if(CMAKE_C_COMPILER_ID STREQUAL "Clang")
-    target_link_libraries(mshtml mingwex)
-endif()
-
 add_delay_importlibs(mshtml wininet)
 add_importlibs(mshtml urlmon shlwapi shell32 ole32 oleaut32 user32 gdi32 advapi32 msvcrt kernel32 ntdll)
 add_dependencies(mshtml mshtml_nsiface_header)