[CMAKE]
[reactos.git] / dll / win32 / mshtml / CMakeLists.txt
index 72bb2e4..4992608 100644 (file)
@@ -1,6 +1,4 @@
 
-ADD_INTERFACE_DEFINITIONS(mshtml_nsiface_header nsiface.idl)
-
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
@@ -11,9 +9,13 @@ add_definitions(
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
+add_idl_Headers(mshtml_nsiface_header nsiface.idl)
+
+set_rc_compiler()
+
 spec2def(mshtml.dll mshtml.spec)
 
-add_library(mshtml SHARED
+list(APPEND SOURCE
     conpoint.c
     dispex.c
     editor.c
@@ -76,8 +78,11 @@ add_library(mshtml SHARED
     txtrange.c
     view.c
     rsrc.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/mshtml_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/mshtml.def)
 
+add_library(mshtml SHARED ${SOURCE})
+
 set_module_type(mshtml win32dll)
 
 target_link_libraries(mshtml
@@ -87,7 +92,6 @@ target_link_libraries(mshtml
     oldnames)
 
 add_importlibs(mshtml
-#    msvcrt
     urlmon
     shlwapi
     ole32
@@ -96,8 +100,9 @@ add_importlibs(mshtml
     gdi32
     advapi32
     wininet
+    msvcrt
     kernel32
     ntdll)
 
 add_dependencies(mshtml mshtml_nsiface_header)
-add_cab_target(mshtml 1)
+add_cd_file(TARGET mshtml DESTINATION reactos/system32)