[CMAKE]
[reactos.git] / dll / win32 / mshtml / CMakeLists.txt
index 8714e3b..4f174ee 100644 (file)
@@ -9,7 +9,7 @@ add_definitions(
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-add_interface_definitions(mshtml_nsiface_header nsiface.idl)
+add_idl_Headers(mshtml_nsiface_header nsiface.idl)
 
 set_rc_compiler()
 
@@ -78,6 +78,7 @@ list(APPEND SOURCE
     txtrange.c
     view.c
     rsrc.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/mshtml_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/mshtml.def)
 
 add_library(mshtml SHARED ${SOURCE})
@@ -104,4 +105,4 @@ add_importlibs(mshtml
     ntdll)
 
 add_dependencies(mshtml mshtml_nsiface_header)
-add_cab_target(mshtml 1)
+add_cd_file(TARGET mshtml DESTINATION reactos/system32 FOR all)