[CMAKE]
[reactos.git] / dll / win32 / msi / CMakeLists.txt
index 668545c..51aa185 100644 (file)
@@ -5,6 +5,7 @@ add_definitions(-D__WINESRC__ -DMSIRUNMODE=MSIRUNMODE_T)
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
+set_rc_compiler()
 spec2def(msi.dll msi.spec)
 
 generate_idl_iids(msiserver.idl)
@@ -13,6 +14,7 @@ list(APPEND SOURCE
     action.c
     alter.c
     appsearch.c
+       assembly.c
     automation.c
     classes.c
     cond.tab.c
@@ -59,6 +61,10 @@ list(APPEND SOURCE
     ${CMAKE_CURRENT_BINARY_DIR}/msi_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/msi.def)
 
+if(MSVC)
+    set_source_files_properties(custom.c PROPERTIES COMPILE_FLAGS /FImsvchelper.h)
+endif()
+
 add_library(msi SHARED ${SOURCE})
 
 add_idl_Headers(msi_idlheader msiserver.idl)
@@ -89,5 +95,5 @@ add_importlibs(msi
     kernel32
     ntdll)
 
-add_cab_target(msi 1)
+add_cd_file(TARGET msi DESTINATION reactos/system32)
 add_importlib_target(msi.spec)