* Sync up to trunk HEAD (r62286).
[reactos.git] / dll / win32 / msports / CMakeLists.txt
index e94d107..53a4096 100644 (file)
@@ -8,14 +8,17 @@ list(APPEND SOURCE
     msports.c
     parallel.c
     serial.c
+    precomp.h
+    ${CMAKE_CURRENT_BINARY_DIR}/msports_stubs.c)
+
+add_library(msports SHARED
+    ${SOURCE}
     msports.rc
-    ${CMAKE_CURRENT_BINARY_DIR}/msports_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/msports.def)
 
-add_library(msports SHARED ${SOURCE})
 set_module_type(msports win32dll UNICODE)
 target_link_libraries(msports wine)
 add_importlibs(msports setupapi comctl32 user32 advapi32 msvcrt kernel32 ntdll)
-add_pch(msports precomp.h)
+add_pch(msports precomp.h SOURCE)
 add_cd_file(TARGET msports DESTINATION reactos/system32 FOR all)