[CMAKE]
[reactos.git] / dll / win32 / msrle32 / CMakeLists.txt
index 659cb8a..b1ef8a0 100644 (file)
@@ -1,19 +1,22 @@
 
-add_definitions(-D__WINESRC__)
-add_definitions(-D_DLL -D__USE_CRTIMP)
+add_definitions(
+    -D__WINESRC__
+    -D_DLL -D__USE_CRTIMP)
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-spec2def(msrle32 ${CMAKE_CURRENT_SOURCE_DIR}/msrle32.spec ${CMAKE_CURRENT_BINARY_DIR}/msrle32.def)
+set_rc_compiler()
 
-add_library(msrle32 SHARED msrle32.c rsrc.rc)
+spec2def(msrle32.dll msrle32.spec)
 
-set_module_type(msrle32 win32dll)
+list(APPEND SOURCE
+    msrle32.c
+    rsrc.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/msrle32.def)
 
-target_link_libraries(msrle32
-    ${CMAKE_CURRENT_BINARY_DIR}/msrle32.def
-    wine)
+add_library(msrle32 SHARED ${SOURCE})
 
+set_module_type(msrle32 win32dll)
+target_link_libraries(msrle32 wine)
 add_importlibs(msrle32 msvcrt winmm user32 kernel32 ntdll)
-add_dependencies(msrle32 msrle32_def)
-add_livecd_target(msrle32 reactos/system32)
+add_cd_file(TARGET msrle32 DESTINATION reactos/system32)