[MSVFW32] Sync with Wine Staging 3.3. CORE-14434
[reactos.git] / dll / win32 / msvfw32 / CMakeLists.txt
index c5cbcc0..4bf2590 100644 (file)
@@ -1,14 +1,14 @@
 
 add_definitions(-D__WINESRC__)
 add_definitions(-D_WINE)
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
+include_directories(BEFORE ${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine)
 spec2def(msvfw32.dll msvfw32.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
     mciwnd.c
     msvideo_main.c
     drawdib.c
-    msvideo_private.h
+    precomp.h
     ${CMAKE_CURRENT_BINARY_DIR}/msvfw32_stubs.c)
 
 add_library(msvfw32 SHARED
@@ -19,5 +19,5 @@ add_library(msvfw32 SHARED
 set_module_type(msvfw32 win32dll)
 target_link_libraries(msvfw32 wine)
 add_importlibs(msvfw32 winmm comctl32 user32 gdi32 advapi32 msvcrt kernel32 ntdll)
-add_pch(msvfw32 msvideo_private.h SOURCE)
+add_pch(msvfw32 precomp.h SOURCE)
 add_cd_file(TARGET msvfw32 DESTINATION reactos/system32 FOR all)