* Sync up to trunk HEAD (r62286).
[reactos.git] / dll / win32 / mswsock / CMakeLists.txt
index 72ab98b..ac10be5 100644 (file)
@@ -8,13 +8,15 @@ spec2def(mswsock.dll mswsock.spec ADD_IMPORTLIB)
 list(APPEND SOURCE
     extensions.c
     stubs.c
+    precomp.h)
+
+add_library(mswsock SHARED
+    ${SOURCE}
     mswsock.rc
     ${CMAKE_CURRENT_BINARY_DIR}/mswsock.def)
 
-add_library(mswsock SHARED ${SOURCE})
-
 set_module_type(mswsock win32dll UNICODE)
 add_importlibs(mswsock ws2_32 msvcrt kernel32)
-add_pch(mswsock precomp.h)
+add_pch(mswsock precomp.h SOURCE)
 add_cd_file(TARGET mswsock DESTINATION reactos/system32 FOR all)