[CMAKE]
[reactos.git] / dll / win32 / msxml3 / CMakeLists.txt
index 30b26b8..a816dec 100644 (file)
@@ -1,5 +1,5 @@
 
-ADD_TYPELIB(msxml3_v1 msxml3_v1.idl)
+add_typelib(msxml3_v1 msxml3_v1.idl)
 add_dependencies(msxml3_v1 stdole2)
 
 remove_definitions(-D_WIN32_WINNT=0x502)
@@ -18,9 +18,10 @@ endif(MSVC)
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
+set_rc_compiler()
 spec2def(msxml3.dll msxml3.spec)
 
-add_library(msxml3 SHARED
+list(APPEND SOURCE
     attribute.c
     comment.c
     domdoc.c
@@ -48,8 +49,11 @@ add_library(msxml3 SHARED
     domimpl.c
     entityref.c
     version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/msxml3_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/msxml3.def)
 
+add_library(msxml3 SHARED ${SOURCE})
+
 set_module_type(msxml3 win32dll)
 
 target_link_libraries(msxml3