[REACTOS] Silence warnings in 3r-party code
[reactos.git] / dll / win32 / netapi32 / CMakeLists.txt
index bbc27a4..0c0c087 100644 (file)
@@ -58,3 +58,8 @@ add_delay_importlibs(netapi32 samlib secur32)
 add_importlibs(netapi32 iphlpapi ws2_32 advapi32 rpcrt4 msvcrt kernel32 ntdll)
 add_pch(netapi32 netapi32.h "${PCH_SKIP_SOURCE}")
 add_cd_file(TARGET netapi32 DESTINATION reactos/system32 FOR all)
+
+if(MSVC)
+    # Disable warning C4267: '=': conversion from 'size_t' to 'USHORT', possible loss of data
+    target_compile_options(netapi32 PRIVATE /wd4267)
+endif()