[CMAKE]
[reactos.git] / dll / win32 / netcfgx / CMakeLists.txt
index 0271a9b..3286fdc 100644 (file)
@@ -1,18 +1,21 @@
-
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
+set_rc_compiler()
 spec2def(netcfgx.dll netcfgx.spec)
 
-add_library(netcfgx SHARED
+list(APPEND SOURCE
     netcfgx.c
     classfactory.c
     netcfg_iface.c
     inetcfgcomp_iface.c
     tcpipconf_notify.c
     netcfgx.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/netcfgx_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/netcfgx.def)
 
+add_library(netcfgx SHARED ${SOURCE})
+
 set_module_type(netcfgx win32dll)
 
 target_link_libraries(netcfgx