[CMAKE]
[reactos.git] / dll / win32 / netcfgx / CMakeLists.txt
index 2edadc8..fb2e955 100644 (file)
@@ -1,24 +1,27 @@
-
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
+set_rc_compiler()
 spec2def(netcfgx.dll netcfgx.spec)
 
-add_library(netcfgx SHARED
+list(APPEND SOURCE
     netcfgx.c
     classfactory.c
     netcfg_iface.c
     inetcfgcomp_iface.c
     tcpipconf_notify.c
     netcfgx.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/netcfgx_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/netcfgx.def)
 
+add_library(netcfgx SHARED ${SOURCE})
+
 set_module_type(netcfgx win32dll)
 
 target_link_libraries(netcfgx
     uuid
     wine)
 
-add_importlibs(netcfgx rpcrt4 setupapi advapi32 iphlpapi ole32 user32 comctl32 ws2_32 kernel32 ntdll)
+add_importlibs(netcfgx rpcrt4 setupapi advapi32 iphlpapi ole32 user32 comctl32 ws2_32 msvcrt kernel32 ntdll)
 
-add_cab_target(netcfgx 1)
+add_cd_file(TARGET netcfgx DESTINATION reactos/system32 FOR all)